package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9][0-9]*$`)
var str = `12310`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}