re = /\b(?:(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?:25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\b/
str = '192.168.2.2'
# Print the match result
str.match(re) do |match|
puts match.to_s
end