# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{4}-[01]\d-[0-3]\dT[0-2]\d:[0-5]\d:[0-5]\d\.\d+([+-][0-2]\d:[0-5]\d|Z))|(\d{4}-[01]\d-[0-3]\dT[0-2]\d:[0-5]\d:[0-5]\d([+-][0-2]\d:[0-5]\d|Z))|(\d{4}-[01]\d-[0-3]\dT[0-2]\d:[0-5]\d([+-][0-2]\d:[0-5]\d|Z))$"
test_str = (" 2009-12T12:34\n\n"
"2009\n"
"2009-05-19T08:39:22.000Z\n\n"
"2009-05-19\n\n"
"2009-05-19\n\n"
"20090519\n\n"
"2009123\n\n"
"2009-05\n\n"
"2009-123\n\n"
"2009-222\n\n"
"2009-001\n\n"
"2009-W01-1\n\n"
"2009-W51-1\n\n"
"2009-W511\n\n"
"2009-W33\n\n"
"2009W511\n\n"
"2009-05-19\n\n"
"2009-05-19 00:00\n\n"
"2009-05-19 14\n\n"
"2009-05-19 14:31\n\n"
"2009-05-19 14:39:22\n\n"
"2009-05-19T14:39Z\n\n"
"2009-W21-2\n\n"
"2009-W21-2T01:22\n\n"
"2009-139\n\n"
"2009-05-19 14:39:22-06:00\n\n"
"2009-05-19 14:39:22+0600\n\n"
"2009-05-19 14:39:22-01\n\n"
"20090621T0545Z\n\n"
"2007-04-06T00:00\n\n"
"2007-04-05T24:00\n\n"
"2010-02-18T16:23:48.5\n\n"
"2010-02-18T16:23:48,444\n\n"
"2010-02-18T16:23:48,3-06:00\n\n"
"2010-02-18T16:23.4\n\n"
"2010-02-18T16:23,25\n\n"
"2010-02-18T16:23.33+0600\n\n"
"2010-02-18T16.23334444\n\n"
"2010-02-18T16,2283\n\n"
"2009-05-19 143922.500\n\n"
"2009-05-19 1439,55")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.