const regex = /^spotify\/streams\/\d{8}\/[A-Z]{2}_streams_\d{8}\.csv/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^spotify\\\/streams\\\/\\d{8}\\\/[A-Z]{2}_streams_\\d{8}\\.csv', 'gm')
const str = `spotify/streams/20200819/NL_streams_20200819.csv
spotify/streams/20200819/nl_streams_20200819.csv
test/spotify/tracks
spotify/tracks/hello.world`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}