re = /!\[\]\(https.*(\.png|\.jpg)\)/m
str = '![](https://remnote-user-data.s3.amazonaws.com/Gh01K1pO8cilN9MVUwXPzQIqt1AZqtpN3kQZQ2IMbkBQlJZY-B7TLJE1wFx9JHX_dZ7JffyEfXYED65U-IgmpBO9bAMQ7d0_3SrZ3SVxyEqeAx5mug2hj0rqeT4sj9.png)
![](https://m.media-amazon.com/images/I/71fyGq6C0YL._SL1500_.jpg){:height 40, :width 80}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end