# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = (r"\n"
r"(\d+)\t(\d+)")
test_str = ("\n"
"6 9\n\n"
"6 10\n\n"
"8 11\n\n"
"9 12\n\n"
"10 13\n\n"
"11 14\n\n"
"12 15\n\n"
"13 16\n\n"
"14 17\n\n"
"15 18\n\n"
"16 19\n\n"
"17 20\n\n"
"18 21\n\n"
"19 22\n\n"
"20 23\n\n"
"5 24\n\n"
"4 25\n\n"
"21 26\n\n"
"22 27\n\n"
"1 28\n\n"
"23 29\n\n"
"24 30\n\n"
"25 31\n\n"
"26 32\n\n"
"27 33\n\n"
"28 34\n\n"
"29 35\n\n"
"30 36\n\n"
"31 37\n\n"
"32 38\n\n"
"33 39\n\n"
"34 40\n\n"
"35 41\n\n"
"36 42\n\n"
"37 43\n\n"
"38 44\n\n"
"39 45\n\n"
"40 46\n\n"
"41 47\n\n"
"42 48\n\n"
"43 49\n\n"
"44 50\n\n"
"45 51\n\n"
"46 52\n\n"
"47 53\n\n"
"48 54\n\n"
"49 55")
subst = "INSERT INTO loyalty_rule(rule_id_fk, loyalty_id_fk) VALUES ($1, $2);"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.