#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)[a-z](?:[a-z]|\d|[+-.])*:(?:\/\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|:)*@)?(?:\[(?:(?:[0-9a-f]{1,4}:){6}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|::(?:[0-9a-f]{1,4}:){5}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){4}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:)?[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){3}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,2}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){2}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,3}[0-9a-f]{1,4})?::[0-9a-f]{1,4}:(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,4}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,5}[0-9a-f]{1,4})?::[0-9a-f]{1,4}|(?:(?:[0-9a-f]{1,4}:){0,6}[0-9a-f]{1,4})?::|v(?:[0-9a-f])+\.(?:[a-z]|\d|[-._~]|[!$&'()*+,;=]|:)+)]|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=])*)(?::(?:\d)*)?(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*)?|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|)(?:\?(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?(?:#(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?|(?:\/\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|:)*@)?(?:\[(?:(?:[0-9a-f]{1,4}:){6}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|::(?:[0-9a-f]{1,4}:){5}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){4}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:)?[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){3}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,2}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:){2}(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,3}[0-9a-f]{1,4})?::[0-9a-f]{1,4}:(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,4}[0-9a-f]{1,4})?::(?:[0-9a-f]{1,4}:[0-9a-f]{1,4}|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d))|(?:(?:[0-9a-f]{1,4}:){0,5}[0-9a-f]{1,4})?::[0-9a-f]{1,4}|(?:(?:[0-9a-f]{1,4}:){0,6}[0-9a-f]{1,4})?::|v(?:[0-9a-f])+\.(?:[a-z]|\d|[-._~]|[!$&'()*+,;=]|:)+)]|(?:(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)\.){3}(?:25[0-5]|2[0-4]\d|1\d\d|[1-9]\d|\d)|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=])*)(?::(?:\d)*)?(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|\/(?:(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*)?|(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|@){1,}(?:\/(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@])*)*|)(?:\?(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?(?:#(?:[a-z]|\d|[-._~]|%[0-9a-f]{2}|[!$&'()*+,;=]|[:@]|[/?])*)?"
Local $sString = "local://[A:A:A:A:A:A::AFCE]//kill/0"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")