$re = '/cr((?!cr)[^.])*(?=\.[^.]+$)/m';
$str = 'cr US TRUMP DE NIRO 20161008cr_x080b.wmv
crcrUS TRUMP DE NIRO 20161008cr.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);