$re = '/^[0-9]*$/m';
$str = '3434 sdw
231231
adad3131dasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);