# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^tf_horovod_(.*?)_(\d*)_(\d*)\/.*total images\/sec: (\d*).(\d*)$"
test_str = ("tf_horovod_alexnet_1_1//tf_horovod_alexnet_1_1_han0044_9841783:total images/sec: 558.63\n"
"tf_horovod_alexnet_1_10//tf_horovod_alexnet_1_10_han0012_9841791:total images/sec: 3738.39\n"
"tf_horovod_alexnet_1_12//tf_horovod_alexnet_1_12_han0002_9841792:total images/sec: 4367.44\n"
"tf_horovod_alexnet_1_14//tf_horovod_alexnet_1_14_han0012_9841793:total images/sec: 5028.34\n"
"tf_horovod_alexnet_1_16//tf_horovod_alexnet_1_16_han0002_9841794:total images/sec: 5534.41\n"
"tf_horovod_alexnet_1_2//tf_horovod_alexnet_1_2_han0043_9841784:total images/sec: 879.33\n"
"tf_horovod_alexnet_1_3//tf_horovod_alexnet_1_3_han0042_9841785:total images/sec: 1242.05\n"
"tf_horovod_alexnet_1_4//tf_horovod_alexnet_1_4_han0020_9841786:total images/sec: 1593.18\n"
"tf_horovod_alexnet_1_5//tf_horovod_alexnet_1_5_han0025_9841787:total images/sec: 1954.82\n"
"tf_horovod_alexnet_1_6//tf_horovod_alexnet_1_6_han0020_9841788:total images/sec: 2255.87\n"
"tf_horovod_alexnet_1_7//tf_horovod_alexnet_1_7_han0032_9841789:total images/sec: 2630.68\n"
"tf_horovod_alexnet_1_8//tf_horovod_alexnet_1_8_han0002_9841790:total images/sec: 2936.90\n"
"tf_horovod_alexnet_2_1//tf_horovod_alexnet_2_1_han0042_9841795:total images/sec: 727.25\n"
"tf_horovod_alexnet_2_10//tf_horovod_alexnet_2_10_han0002_9841803:total images/sec: 7133.82\n"
"tf_horovod_alexnet_2_2//tf_horovod_alexnet_2_2_han0043_9841796:total images/sec: 1652.27\n"
"tf_horovod_alexnet_2_3//tf_horovod_alexnet_2_3_han0042_9841797:total images/sec: 2244.21\n"
"tf_horovod_alexnet_2_4//tf_horovod_alexnet_2_4_han0023_9841798:total images/sec: 3107.98\n"
"tf_horovod_alexnet_2_5//tf_horovod_alexnet_2_5_han0020_9841799:total images/sec: 3841.47\n"
"tf_horovod_alexnet_2_6//tf_horovod_alexnet_2_6_han0002_9841800:total images/sec: 4565.75\n"
"tf_horovod_alexnet_2_8//tf_horovod_alexnet_2_8_han0017_9841802:total images/sec: 5965.89\n"
"tf_horovod_googlenet_1_1//tf_horovod_googlenet_1_1_han0041_9841735:total images/sec: 111.51\n"
"tf_horovod_googlenet_1_10//tf_horovod_googlenet_1_10_han0012_9841743:total images/sec: 1074.32\n"
"tf_horovod_googlenet_1_12//tf_horovod_googlenet_1_12_han0002_9841744:total images/sec: 1304.12\n"
"tf_horovod_googlenet_1_14//tf_horovod_googlenet_1_14_han0012_9841745:total images/sec: 1501.07\n"
"tf_horovod_googlenet_1_16//tf_horovod_googlenet_1_16_han0002_9841746:total images/sec: 1646.49\n"
"tf_horovod_googlenet_1_2//tf_horovod_googlenet_1_2_han0041_9841736:total images/sec: 219.21\n"
"tf_horovod_googlenet_1_3//tf_horovod_googlenet_1_3_han0041_9841737:total images/sec: 328.94\n"
"tf_horovod_googlenet_1_4//tf_horovod_googlenet_1_4_han0032_9841738:total images/sec: 437.95\n"
"tf_horovod_googlenet_1_5//tf_horovod_googlenet_1_5_han0020_9841739:total images/sec: 546.25\n"
"tf_horovod_googlenet_1_6//tf_horovod_googlenet_1_6_han0031_9841740:total images/sec: 657.16\n"
"tf_horovod_googlenet_1_7//tf_horovod_googlenet_1_7_han0020_9841741:total images/sec: 765.23\n"
"tf_horovod_googlenet_1_8//tf_horovod_googlenet_1_8_han0002_9841742:total images/sec: 842.25\n"
"tf_horovod_googlenet_2_1//tf_horovod_googlenet_2_1_han0044_9841747:total images/sec: 208.41\n"
"tf_horovod_googlenet_2_10//tf_horovod_googlenet_2_10_han0019_9841755:total images/sec: 2166.72\n"
"tf_horovod_googlenet_2_14//tf_horovod_googlenet_2_14_han0016_9841757:total images/sec: 2994.40\n"
"tf_horovod_googlenet_2_2//tf_horovod_googlenet_2_2_han0043_9841748:total images/sec: 441.89\n"
"tf_horovod_googlenet_2_3//tf_horovod_googlenet_2_3_han0042_9841749:total images/sec: 660.91\n"
"tf_horovod_googlenet_2_4//tf_horovod_googlenet_2_4_han0035_9841750:total images/sec: 875.64\n"
"tf_horovod_googlenet_2_5//tf_horovod_googlenet_2_5_han0020_9841751:total images/sec: 1092.19\n"
"tf_horovod_googlenet_2_6//tf_horovod_googlenet_2_6_han0031_9841752:total images/sec: 1293.98\n"
"tf_horovod_googlenet_2_7//tf_horovod_googlenet_2_7_han0002_9841753:total images/sec: 1528.10\n"
"tf_horovod_inception3_1_1//tf_horovod_inception3_1_1_han0002_9841711:total images/sec: 30.58\n"
"tf_horovod_inception3_1_10//tf_horovod_inception3_1_10_han0012_9841719:total images/sec: 275.87\n"
"tf_horovod_inception3_1_12//tf_horovod_inception3_1_12_han0002_9841720:total images/sec: 329.99\n"
"tf_horovod_inception3_1_14//tf_horovod_inception3_1_14_han0016_9841721:total images/sec: 385.50\n"
"tf_horovod_inception3_1_16//tf_horovod_inception3_1_16_han0002_9841722:total images/sec: 439.23\n"
"tf_horovod_inception3_1_2//tf_horovod_inception3_1_2_han0003_9841712:total images/sec: 59.61\n"
"tf_horovod_inception3_1_3//tf_horovod_inception3_1_3_han0007_9841713:total images/sec: 85.70\n"
"tf_horovod_inception3_1_4//tf_horovod_inception3_1_4_han0010_9841714:total images/sec: 113.94\n"
"tf_horovod_inception3_1_5//tf_horovod_inception3_1_5_han0014_9841715:total images/sec: 144.05\n"
"tf_horovod_inception3_1_6//tf_horovod_inception3_1_6_han0019_9841716:total images/sec: 168.36\n"
"tf_horovod_inception3_1_7//tf_horovod_inception3_1_7_han0031_9841717:total images/sec: 193.21\n"
"tf_horovod_inception3_1_8//tf_horovod_inception3_1_8_han0002_9841718:total images/sec: 227.10\n"
"tf_horovod_inception3_2_1//tf_horovod_inception3_2_1_han0044_9841723:total images/sec: 59.86\n"
"tf_horovod_inception3_2_2//tf_horovod_inception3_2_2_han0042_9841724:total images/sec: 115.65\n"
"tf_horovod_inception3_2_3//tf_horovod_inception3_2_3_han0036_9841725:total images/sec: 168.11\n"
"tf_horovod_inception3_2_4//tf_horovod_inception3_2_4_han0020_9841726:total images/sec: 231.98\n"
"tf_horovod_inception3_2_5//tf_horovod_inception3_2_5_han0025_9841727:total images/sec: 281.29\n"
"tf_horovod_inception3_2_6//tf_horovod_inception3_2_6_han0002_9841728:total images/sec: 303.14\n"
"tf_horovod_inception3_2_8//tf_horovod_inception3_2_8_han0017_9841730:total images/sec: 449.13\n"
"tf_horovod_resnet152_1_1//tf_horovod_resnet152_1_1_han0044_9841807:total images/sec: 16.90\n"
"tf_horovod_resnet152_1_10//tf_horovod_resnet152_1_10_han0019_9841815:total images/sec: 147.34\n"
"tf_horovod_resnet152_1_12//tf_horovod_resnet152_1_12_han0002_9841816:total images/sec: 171.81\n"
"tf_horovod_resnet152_1_14//tf_horovod_resnet152_1_14_han0016_9841817:total images/sec: 198.39\n"
"tf_horovod_resnet152_1_16//tf_horovod_resnet152_1_16_han0002_9841818:total images/sec: 223.94\n"
"tf_horovod_resnet152_1_2//tf_horovod_resnet152_1_2_han0042_9841808:total images/sec: 31.69\n"
"tf_horovod_resnet152_1_3//tf_horovod_resnet152_1_3_han0041_9841809:total images/sec: 44.01\n"
"tf_horovod_resnet152_1_4//tf_horovod_resnet152_1_4_han0032_9841810:total images/sec: 58.62\n"
"tf_horovod_resnet152_1_5//tf_horovod_resnet152_1_5_han0020_9841811:total images/sec: 75.68\n"
"tf_horovod_resnet152_1_6//tf_horovod_resnet152_1_6_han0031_9841812:total images/sec: 88.83\n"
"tf_horovod_resnet152_1_7//tf_horovod_resnet152_1_7_han0002_9841813:total images/sec: 98.08\n"
"tf_horovod_resnet152_1_8//tf_horovod_resnet152_1_8_han0011_9841814:total images/sec: 113.42\n"
"tf_horovod_resnet152_2_1//tf_horovod_resnet152_2_1_han0044_9841819:total images/sec: 31.19\n"
"tf_horovod_resnet152_2_14//tf_horovod_resnet152_2_14_han0002_9841829:total images/sec: 381.20\n"
"tf_horovod_resnet152_2_2//tf_horovod_resnet152_2_2_han0043_9841820:total images/sec: 59.06\n"
"tf_horovod_resnet152_2_3//tf_horovod_resnet152_2_3_han0042_9841821:total images/sec: 87.06\n"
"tf_horovod_resnet152_2_4//tf_horovod_resnet152_2_4_han0020_9841822:total images/sec: 123.09\n"
"tf_horovod_resnet152_2_5//tf_horovod_resnet152_2_5_han0025_9841823:total images/sec: 150.62\n"
"tf_horovod_resnet152_2_6//tf_horovod_resnet152_2_6_han0002_9841824:total images/sec: 177.58\n"
"tf_horovod_resnet152_2_8//tf_horovod_resnet152_2_8_han0017_9841826:total images/sec: 239.01\n"
"tf_horovod_resnet50_1_1//tf_horovod_resnet50_1_1_han0043_9841759:total images/sec: 51.27\n"
"tf_horovod_resnet50_1_10//tf_horovod_resnet50_1_10_han0002_9841767:total images/sec: 378.93\n"
"tf_horovod_resnet50_1_12//tf_horovod_resnet50_1_12_han0014_9841768:total images/sec: 455.76\n"
"tf_horovod_resnet50_1_14//tf_horovod_resnet50_1_14_han0002_9841769:total images/sec: 543.73\n"
"tf_horovod_resnet50_1_16//tf_horovod_resnet50_1_16_han0002_9841770:total images/sec: 651.41\n"
"tf_horovod_resnet50_1_2//tf_horovod_resnet50_1_2_han0043_9841760:total images/sec: 86.57\n"
"tf_horovod_resnet50_1_3//tf_horovod_resnet50_1_3_han0042_9841761:total images/sec: 128.79\n"
"tf_horovod_resnet50_1_4//tf_horovod_resnet50_1_4_han0020_9841762:total images/sec: 159.36\n"
"tf_horovod_resnet50_1_5//tf_horovod_resnet50_1_5_han0025_9841763:total images/sec: 238.30\n"
"tf_horovod_resnet50_1_6//tf_horovod_resnet50_1_6_han0002_9841764:total images/sec: 235.31\n"
"tf_horovod_resnet50_1_7//tf_horovod_resnet50_1_7_han0010_9841765:total images/sec: 280.58\n"
"tf_horovod_resnet50_1_8//tf_horovod_resnet50_1_8_han0017_9841766:total images/sec: 290.86\n"
"tf_horovod_resnet50_2_1//tf_horovod_resnet50_2_1_han0043_9841771:total images/sec: 96.62\n"
"tf_horovod_resnet50_2_2//tf_horovod_resnet50_2_2_han0042_9841772:total images/sec: 184.89\n"
"tf_horovod_resnet50_2_3//tf_horovod_resnet50_2_3_han0035_9841773:total images/sec: 240.53\n"
"tf_horovod_resnet50_2_4//tf_horovod_resnet50_2_4_han0020_9841774:total images/sec: 322.29\n"
"tf_horovod_resnet50_2_5//tf_horovod_resnet50_2_5_han0025_9841775:total images/sec: 430.72\n"
"tf_horovod_resnet50_2_6//tf_horovod_resnet50_2_6_han0020_9841776:total images/sec: 582.51\n"
"tf_horovod_resnet50_2_7//tf_horovod_resnet50_2_7_han0002_9841777:total images/sec: 483.72\n"
"tf_horovod_vgg16_1_1//tf_horovod_vgg16_1_1_han0043_9841831:total images/sec: 31.72\n"
"tf_horovod_vgg16_1_10//tf_horovod_vgg16_1_10_han0012_9841839:total images/sec: 182.85\n"
"tf_horovod_vgg16_1_12//tf_horovod_vgg16_1_12_han0002_9841840:total images/sec: 198.60\n"
"tf_horovod_vgg16_1_14//tf_horovod_vgg16_1_14_han0012_9841841:total images/sec: 225.43\n"
"tf_horovod_vgg16_1_16//tf_horovod_vgg16_1_16_han0002_9841842:total images/sec: 272.26\n"
"tf_horovod_vgg16_1_2//tf_horovod_vgg16_1_2_han0018_9841832:total images/sec: 43.32\n"
"tf_horovod_vgg16_1_3//tf_horovod_vgg16_1_3_han0042_9841833:total images/sec: 60.24\n"
"tf_horovod_vgg16_1_4//tf_horovod_vgg16_1_4_han0041_9841834:total images/sec: 77.23\n"
"tf_horovod_vgg16_1_5//tf_horovod_vgg16_1_5_han0031_9841835:total images/sec: 99.26\n"
"tf_horovod_vgg16_1_6//tf_horovod_vgg16_1_6_han0020_9841836:total images/sec: 116.97\n"
"tf_horovod_vgg16_1_7//tf_horovod_vgg16_1_7_han0031_9841837:total images/sec: 127.79\n"
"tf_horovod_vgg16_1_8//tf_horovod_vgg16_1_8_han0002_9841838:total images/sec: 150.32\n"
"tf_horovod_vgg16_2_1//tf_horovod_vgg16_2_1_han0042_9841843:total images/sec: 25.13\n"
"tf_horovod_vgg16_2_14//tf_horovod_vgg16_2_14_han0002_9841853:total images/sec: 457.16\n"
"tf_horovod_vgg16_2_2//tf_horovod_vgg16_2_2_han0043_9841844:total images/sec: 87.63\n"
"tf_horovod_vgg16_2_3//tf_horovod_vgg16_2_3_han0042_9841845:total images/sec: 123.58\n"
"tf_horovod_vgg16_2_4//tf_horovod_vgg16_2_4_han0023_9841846:total images/sec: 154.47\n"
"tf_horovod_vgg16_2_5//tf_horovod_vgg16_2_5_han0020_9841847:total images/sec: 196.85\n"
"tf_horovod_vgg16_2_6//tf_horovod_vgg16_2_6_han0023_9841848:total images/sec: 236.51\n"
"tf_horovod_vgg16_2_7//tf_horovod_vgg16_2_7_han0020_9841849:total images/sec: 262.63\n"
"tf_horovod_vgg16_2_8//tf_horovod_vgg16_2_8_han0002_9841850:total images/sec: 304.16")
subst = "\\1\\t\\3\\t\\3\\t-\\t\\2\\t\\t\\4,\\5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.