#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^([a-z0-9_-]+)(\.[a-z0-9_-]+)?@([a-z0-9_-]+)\.([a-z0-9]{2,})$"
Local $sString = "<header class="noSelect">" & @CRLF & _
" <div id="HIAccueil" class="I-B">" & @CRLF & _
" <img class="pointer" src="IMG/BACKGROUND/HEADER/logoban.png" alt="Accueil" onclick="clickMenu(tousLesMenus, 2, tousLesMenus[0].nom, 1, 0, 0, 0, tousLesMenus[1].url);">" & @CRLF & _
" </div>" & @CRLF & _
" <div id="HIPC">" & @CRLF & _
" <div id="HIProfile" class="I-B">" & @CRLF & _
" <!-- vide pour img via js -->" & @CRLF & _
" </div>" & @CRLF & _
" <div id="HIConnect" class="I-B">" & @CRLF & _
" <img class="pointer" src="IMG/BACKGROUND/HEADER/connect_hover.gif" alt="Connect" onclick="clickMenu(tousLesMenus, 5, tousLesMenus[0].nom, 4, 1, 1, 0, tousLesMenus[4].url);">" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</header>" & @CRLF & _
"Tralloc_Nivek-02.baza_R-d421@gmail45.com" & @CRLF & _
"Tralloc_Nivek-02@gmail45.com" & @CRLF & _
"Tralloc_Nivek-02.baza_R-d421gmail45.c" & @CRLF & _
"" & @CRLF & _
"010/226679" & @CRLF & _
"010226679" & @CRLF & _
"010/22.66.79" & @CRLF & _
"010/22 66 79" & @CRLF & _
"0470040747" & @CRLF & _
"0470/040747" & @CRLF & _
"0470/040.747" & @CRLF & _
"0470/04.07.47" & @CRLF & _
"0470/04 07 47" & @CRLF & _
"0470/040 747" & @CRLF & _
"+0032470040747" & @CRLF & _
"0032470/040 747" & @CRLF & _
"+00320470040747"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")