using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*?)([^\s](?:[^\s\'\""\[\(]+(?:\'[^\']*\'|\[[^\]]*\]|\""[^\""]*\""|\([^\)]*\))*)*)$";
string input = @"body test[name='ab'] test2:contains( [ 'a text '] )";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}