#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\h*<xen:if is="{\$debugMode}">" & @CRLF & _
"\h*<xen:if hascontent="true">" & @CRLF & _
"\h*<dl class="pairsInline debugInfo".*?>" & @CRLF & _
"(\h*)<xen:contentcheck>"
Local $sString = "<xen:edithint template="footer.css" />" & @CRLF & _
"" & @CRLF & _
"<xen:hook name="footer">" & @CRLF & _
"<div class="footer">" & @CRLF & _
" <div class="pageWidth">" & @CRLF & _
" <div class="pageContent">" & @CRLF & _
" <xen:if is="{$canChangeStyle} OR {$canChangeLanguage}">" & @CRLF & _
" <dl class="choosers">" & @CRLF & _
" <xen:if is="{$canChangeStyle}">" & @CRLF & _
" <dt>{xen:phrase style}</dt>" & @CRLF & _
" <dd><a href="{xen:link 'misc/style', '', 'redirect={$requestPaths.requestUri}'}" class="OverlayTrigger Tooltip" title="{xen:phrase style_chooser}" rel="nofollow">{$visitorStyle.title}</a></dd>" & @CRLF & _
" </xen:if>" & @CRLF & _
" <xen:if is="{$canChangeLanguage}">" & @CRLF & _
" <dt>{xen:phrase language}</dt>" & @CRLF & _
" <dd><a href="{xen:link 'misc/language', '', 'redirect={$requestPaths.requestUri}'}" class="OverlayTrigger Tooltip" title="{xen:phrase language_chooser}" rel="nofollow">{$visitorLanguage.title}</a></dd>" & @CRLF & _
" </xen:if>" & @CRLF & _
" </dl>" & @CRLF & _
" </xen:if>" & @CRLF & _
" " & @CRLF & _
" <ul class="footerLinks">" & @CRLF & _
" <xen:hook name="footer_links">" & @CRLF & _
" <xen:if is="{$xenOptions.contactUrl.type} === 'default'">" & @CRLF & _
" <li><a href="{xen:link 'misc/contact'}" class="OverlayTrigger" data-overlayOptions="{"fixed":false}">{xen:phrase contact_us}</a></li>" & @CRLF & _
" <xen:elseif is="{$xenOptions.contactUrl.type} === 'custom'" />" & @CRLF & _
" <li><a href="{$xenOptions.contactUrl.custom}" {xen:if {$xenOptions.contactUrl.overlay}, 'class="OverlayTrigger" data-overlayOptions="{"fixed":false}"'}>{xen:phrase contact_us}</a></li>" & @CRLF & _
" </xen:if>" & @CRLF & _
" <li><a href="{xen:link help}">{xen:phrase help}</a></li>" & @CRLF & _
" <xen:if is="{$homeLink}"><li><a href="{$homeLink}" class="homeLink">{xen:phrase home}</a></li></xen:if>" & @CRLF & _
" <li><a href="{$requestPaths.requestUri}#navigation" class="topLink">{xen:phrase go_to_top}</a></li>" & @CRLF & _
" <li><a href="{xen:link forums/-/index.rss}" rel="alternate" class="globalFeed" target="_blank"" & @CRLF & _
" title="{xen:phrase rss_feed_for_x, 'title={$xenOptions.boardTitle}'}">{xen:phrase rss}</a></li>" & @CRLF & _
" </xen:hook>" & @CRLF & _
" </ul>" & @CRLF & _
" " & @CRLF & _
" <span class="helper"></span>" & @CRLF & _
" </div>" & @CRLF & _
" </div>" & @CRLF & _
"</div>" & @CRLF & _
"" & @CRLF & _
"<div class="footerLegal">" & @CRLF & _
" <div class="pageWidth">" & @CRLF & _
" <div class="pageContent">" & @CRLF & _
" <ul id="legal">" & @CRLF & _
" <xen:hook name="footer_links_legal">" & @CRLF & _
" <xen:if is="{$tosUrl}"><li><a href="{$tosUrl}">{xen:phrase terms_and_rules}</a></li></xen:if>" & @CRLF & _
" <xen:if is="{$xenOptions.privacyPolicyUrl}"><li><a href="{$xenOptions.privacyPolicyUrl}">{xen:phrase privacy_policy}</a></li></xen:if>" & @CRLF & _
" </xen:hook>" & @CRLF & _
" </ul>" & @CRLF & _
" " & @CRLF & _
" <div id="copyright">{xen:helper copyright} {xen:phrase extra_copyright}</div>" & @CRLF & _
" <xen:hook name="footer_after_copyright" />" & @CRLF & _
" " & @CRLF & _
" <xen:if is="{$debugMode}">" & @CRLF & _
" <xen:if hascontent="true">" & @CRLF & _
" <dl class="pairsInline debugInfo" title="{$controllerName}->{$controllerAction}{xen:if $viewName, ' ({$viewName})'}">" & @CRLF & _
" <xen:contentcheck>" & @CRLF & _
" <xen:if is="{$page_time}"><dt>{xen:phrase timing}:</dt> <dd><a href="{$debug_url}" rel="nofollow">{xen:phrase x_seconds, 'time={xen:number $page_time, 4}'}</a></dd></xen:if>" & @CRLF & _
" <xen:if is="{$memory_usage}"><dt>{xen:phrase memory}:</dt> <dd>{xen:phrase x_mb, 'size={xen:number {xen:calc "{$memory_usage} / 1024 / 1024"}, 3}'}</dd></xen:if>" & @CRLF & _
" <xen:if is="{$db_queries}"><dt>{xen:phrase db_queries}:</dt> <dd>{xen:number {$db_queries}}</dd></xen:if>" & @CRLF & _
" </xen:contentcheck>" & @CRLF & _
" </dl>" & @CRLF & _
" </xen:if>" & @CRLF & _
" </xen:if>" & @CRLF & _
" " & @CRLF & _
" <span class="helper"></span>" & @CRLF & _
" </div>" & @CRLF & _
" </div> " & @CRLF & _
"</div>" & @CRLF & _
"</xen:hook>"
Local $sSubst = "$0\n$1 <!-- Adding XenForo version strings -->\n$1 <dt>XenForo Version:<dt> <dd>{$xenOptions.currentVersion} ({$xenOptions.currentVersionId})</dd>\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)