import Foundation
let pattern = #"([A-Z][a-z]+(?=\s[A-Z])(?:\s[A-Z][a-z]+)+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Malaysia’s central bank had to take action against a debt-ridden state investment company to protect the integrity of the financial system, according to governor Zeti Akhtar Aziz, who said an improvement in the country’s political situation would help the ringgit.
The attorney-general’s office earlier this month dismissed Bank Negara Malaysia's second request for criminal proceedings against 1Malaysia Development Bhd (1MDB) for breaching the Exchange Control Act.
Bank Negara has revoked three permissions given to 1MDB for investments abroad totalling $1.83 billion, and instructed it to repatriate the amount.
"He has the right to make that assessment," Zeti said, referring to the attorney-general. "But for the central bank, we believe it is very, very important to comply with our rules and regulations that we have in place. This is vital, it’s critical for the functioning of the financial system" and its integrity, she said.
While growth could ease to as little as 4.8 percent this year and the risk of a slowdown because of the global economy is bigger than the threat of inflation, Malaysia has a “high degree of resilience”, Zeti, 68, said in an interview in Lima, Peru, on Sunday.
The central bank doesn’t see the risk of faster inflation after the first quarter of 2016 and interest rates at current levels are supportive of growth, Zeti said. Malaysia forecasts growth of 4.5 percent to 5.5 percent this year.
Confidence struggle
Malaysian policy makers have struggled to boost confidence in the economy and its finances since oil prices started slumping late last year and as allegations of financial irregularities at 1MDB hurt sentiments.
Tensions in the Southeast Asian nation have also increased as Prime Minister Najib Abdul Razak (photo) battled accusations of impropriety over political donations that ended up in his private accounts.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)