re = /^(0\d:[0-5]\d)|(^1[01]:[0-5]\d)|(^12:[0-2]\d)|(^12:3[0-5])/m
str = '00:00
01:00
02:00
03:00
04:00
05:00
06:00
07:00
08:00
09:00
10:00
11:00
12:00
12:09
12:19
12:29
12:30
12:31
12:32
12:33
12:34
12:35 midday (all days of week)
12:36
13:00
14:00
15:00
16:00
17:00
18:00
19:00
19:35 evening (sun-fri)
20:00
20:05 evening (saturday)
21:00
22:00
23:00'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end