package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)ab+[eE0-9]+`)
var str = `abbbbb123xyababbbbbbbbe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}