re = /(Jan(uary)?|Feb(ruary)?|Mar(ch)?|Apr(il)?|May|June?|July?|Aug(ust)?|Sep(t(ember)?)?|Oct(ober)?|Nov(ember)?|Dec(ember)?)[ ](3[01]|[12][0-9]|[0][1-9]|[1-9])[,][ ](20\d{2})/
str = 'The owners of this address received a permit on Wednesday, June 12, 2014
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end