$re = '/-*[0-9]+[.]*[0-9]*/';
$str = '156.32343234124 dfsfsf -123.32424124 esfdfd 32.2342523';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);