re = /^((((25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)))\s*([,;\s*]|$)+)*/
str = '192.168.3.1 ; 192.168.1.2 ,'
# Print the match result
str.match(re) do |match|
puts match.to_s
end