#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).{5}-.{5}-.{5}"
Local $sString = "45Y43-04T52-JDLH2" & @CRLF & _
"8YZIH-2QKFB-3KFFQ" & @CRLF & _
"44P78-J74GI-4L9AF" & @CRLF & _
"BTHGF-WL500-C0R4V" & @CRLF & _
"6RM9G-N9XFP-VCJRQ" & @CRLF & _
"IEA6K-QMFHN-YVYP9" & @CRLF & _
"XNWHC-PR7XT-NP2KL" & @CRLF & _
"JRFCZ-XDQB3-4YRX3" & @CRLF & _
"4V8YN-L0DRV-CIWJ7" & @CRLF & _
"56LPR-3B48C-746IK" & @CRLF & _
"BDFW4-V9NZ5-JGTKZ" & @CRLF & _
"L2FJZ-DBC2I-4CA53" & @CRLF & _
"GEBFT-A8W6J-NHNA5" & @CRLF & _
"" & @CRLF & _
"6BRKC-TJZBC-W7E4E" & @CRLF & _
"" & @CRLF & _
"Tanuki Sunset (2020)" & @CRLF & _
"Skateboarding Racoons" & @CRLF & _
"Redemption Key: EZ6KQ-Q843I-4VR2K" & @CRLF & _
"" & @CRLF & _
"Swords 'n Magic and Stuff EA (2020)" & @CRLF & _
"Cute Multiplayer RPG" & @CRLF & _
"Redemption Key: V9KCM-ETNCK-783FC" & @CRLF & _
"" & @CRLF & _
"Sunlight (2021)" & @CRLF & _
"Chilled, wholesome trees" & @CRLF & _
"Redemption Key: 6XBXM-PLY8B-BH6ZI" & @CRLF & _
"" & @CRLF & _
"Space Crew (2020)" & @CRLF & _
"Space Management Adventure" & @CRLF & _
"Redemption Key: I24W9-5HVWA-WVVF0" & @CRLF & _
"" & @CRLF & _
"Sok-worlds (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: KLDH9-6MN8R-HGIM8" & @CRLF & _
"" & @CRLF & _
"Seals of the Bygone EA (2020)" & @CRLF & _
"Roguelike Dungeon Delver" & @CRLF & _
"Redemption Key: 5K984-GVM78-M0XKI" & @CRLF & _
"" & @CRLF & _
"Pyramida (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: VDVCZ-VQDFA-RGTD2" & @CRLF & _
"" & @CRLF & _
"Primal Light (2020)" & @CRLF & _
"16bit Boss Battler" & @CRLF & _
"Redemption Key: CIIF5-YZCV3-D5W5Z" & @CRLF & _
"" & @CRLF & _
"Popo's Tower (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: M8F2X-M39FD-X2QEC" & @CRLF & _
"" & @CRLF & _
"Pocket Watch (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: CTENC-YQRX2-WJFDE" & @CRLF & _
"" & @CRLF & _
"PlateUp! (2022)" & @CRLF & _
"Brilliant Cooking Chaos" & @CRLF & _
"Redemption Key: LCW28-X8FNM-PMC25" & @CRLF & _
"" & @CRLF & _
"Plague Inc: Evolved (2016)" & @CRLF & _
"End The World" & @CRLF & _
"Redemption Key: C7DJ7-P89MM-XNP6F" & @CRLF & _
"" & @CRLF & _
"Pendragon (2020)" & @CRLF & _
"Mythic Tactical Narrative" & @CRLF & _
"Redemption Key: F7AAG-9J2M4-2ZP7W" & @CRLF & _
"" & @CRLF & _
"Paradise Lost (2021)" & @CRLF & _
"Postapocalyptic Adventure" & @CRLF & _
"Redemption Key: ZJP3N-YW9BJ-9QLNA" & @CRLF & _
"" & @CRLF & _
"Paperball (2020)" & @CRLF & _
"Stunt Ball Racing" & @CRLF & _
"Redemption Key: JXBRJ-B20WN-6YZDT" & @CRLF & _
"" & @CRLF & _
"Orbi Universo (2020)" & @CRLF & _
"Abstract Civ Strategy" & @CRLF & _
"Redemption Key: RBBXD-02R4I-ZBCWN" & @CRLF & _
"" & @CRLF & _
"Moon Hunters (2016)" & @CRLF & _
"Tiny DnD Adventures" & @CRLF & _
"Redemption Key: 6QPQ5-Y4XYI-MWXRX" & @CRLF & _
"" & @CRLF & _
"Men of War: Assault Squad 2 (2014)" & @CRLF & _
"Tanks Troops Tactics" & @CRLF & _
"Redemption Key: 0BA6C-39RXP-LF0P2" & @CRLF & _
"" & @CRLF & _
"Mech Mechanic Sim (2021)" & @CRLF & _
"Build-a-mech workshop" & @CRLF & _
"Redemption Key: C45EI-0G6HZ-VWWW4" & @CRLF & _
"" & @CRLF & _
"Maiden and Spell (2020)" & @CRLF & _
"Flying Magic Bullet-hell" & @CRLF & _
"Redemption Key: 54EGK-4WR22-F2CPT" & @CRLF & _
"" & @CRLF & _
"Mad Experiments: Escape Room (2020)" & @CRLF & _
"Mind-bending Escape Room" & @CRLF & _
"Redemption Key: T896H-F6XHH-H77PJ" & @CRLF & _
"" & @CRLF & _
"Lucifer Within Us (2020)" & @CRLF & _
"Intricate Demonic Detective" & @CRLF & _
"Redemption Key: QJNJ6-R709L-JZJ27" & @CRLF & _
"" & @CRLF & _
"Lost Nova (2022)" & @CRLF & _
"Explore Build Craft" & @CRLF & _
"Redemption Key: YD66M-DW407-TXBY4" & @CRLF & _
"" & @CRLF & _
"Little Inferno (2012)" & @CRLF & _
"Burn Your Toys" & @CRLF & _
"Redemption Key: 2FDDH-BVHCF-ZGMRG" & @CRLF & _
"" & @CRLF & _
"Kitaria Fables (2021)" & @CRLF & _
"ARPG with Farming" & @CRLF & _
"Redemption Key: CR79H-XXQ39-XR326" & @CRLF & _
"" & @CRLF & _
"King Pins (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: G664K-X90Y4-TI3JL" & @CRLF & _
"" & @CRLF & _
"KILLRUN (2022)" & @CRLF & _
"Run Gun Parkour!" & @CRLF & _
"Redemption Key: ZQMBT-8LLNX-PLP6W" & @CRLF & _
"" & @CRLF & _
"Kaiju Wars (2022)" & @CRLF & _
"Monster Mashing Tactics" & @CRLF & _
"Redemption Key: JBAMA-7DNZT-PCFK9" & @CRLF & _
"" & @CRLF & _
"JARS (2021)" & @CRLF & _
"Creepy Puzzles" & @CRLF & _
"Redemption Key: MJY23-KB8DY-AVM9E" & @CRLF & _
"" & @CRLF & _
"Imagine Earth (2021)" & @CRLF & _
"Planetary Colonization" & @CRLF & _
"Redemption Key: IRENW-AD95D-W8XZY" & @CRLF & _
"" & @CRLF & _
"Idle Champions - Prismeer Sentry Skin & Feat Pack (2022)" & @CRLF & _
"Buff Your Champion" & @CRLF & _
"Redemption Key: 3H8T8-JD6C0-WTFEL" & @CRLF & _
"" & @CRLF & _
"Idle Champions - Polymorphed Shandie Skin & Feat Pack (2022)" & @CRLF & _
"Buff Your Champion" & @CRLF & _
"Redemption Key: D29T4-W9JV6-YZB6C" & @CRLF & _
"" & @CRLF & _
"House (2020)" & @CRLF & _
"Spooky Pixel House" & @CRLF & _
"Redemption Key: 3EZRM-9F8E8-4BD0R" & @CRLF & _
"" & @CRLF & _
"Here Comes Niko! (2021)" & @CRLF & _
"Cute Cozy Platforming" & @CRLF & _
"Redemption Key: XXBKJ-KNQ7R-BKPYZ" & @CRLF & _
"" & @CRLF & _
"Hellblusser (2021)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: C4IC8-5YY5B-8NMLM" & @CRLF & _
"" & @CRLF & _
"Geneshift EA (2017)" & @CRLF & _
"Cars Guns Action" & @CRLF & _
"Redemption Key: ELNYT-TM9C6-36NNC" & @CRLF & _
"" & @CRLF & _
"Fury Unleashed (2020)" & @CRLF & _
"Frantic Roguelike Shooter" & @CRLF & _
"Redemption Key: M96X5-5647E-VXFEL" & @CRLF & _
"" & @CRLF & _
"Fresh Store Discount" & @CRLF & _
"25% off these collections; RTGame, High Rollers, Hat Films, Spiffing Brit & ISP, active from Dec 1 to Jan 17590" & @CRLF & _
"Redemption Key: 25HN26" & @CRLF & _
"" & @CRLF & _
"Flipper Volcano (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: HA84M-BAA6B-WXWG2" & @CRLF & _
"" & @CRLF & _
"Fit For a King (2019)" & @CRLF & _
"Marry Divorce Execute" & @CRLF & _
"Redemption Key: BCA7H-8KYAT-RYZ45" & @CRLF & _
"" & @CRLF & _
"First Class Trouble (2021)" & @CRLF & _
"Cruise Ship Among Us" & @CRLF & _
"Redemption Key: XWM5E-8NV7T-6P0HE" & @CRLF & _
"" & @CRLF & _
"Final Vendetta (2022)" & @CRLF & _
"Side Scrolling Brawler" & @CRLF & _
"Redemption Key: ABW65-X9YX8-0L8L3" & @CRLF & _
"" & @CRLF & _
"Fanatical spinning wheel" & @CRLF & _
"redeem your code here: https://www.fanatical.com/en/redeem-code" & @CRLF & _
"Redemption Key: RCtG6PHzzcXXsr" & @CRLF & _
"" & @CRLF & _
"Factory Town (2021)" & @CRLF & _
"Automate Your Town" & @CRLF & _
"Redemption Key: VTMA4-05TF8-7RVK9" & @CRLF & _
"" & @CRLF & _
"Eternal Hope (2020)" & @CRLF & _
"Cinematic Puzzle Platformer" & @CRLF & _
"Redemption Key: 4YFK3-CL7B0-K2559" & @CRLF & _
"" & @CRLF & _
"Epic Battle Fantasy 5 (2018)" & @CRLF & _
"Tongue-in-cheek JRPG" & @CRLF & _
"Redemption Key: YBJWL-VZRAH-9LQIB" & @CRLF & _
"" & @CRLF & _
"Dude, Stop (2018)" & @CRLF & _
"Be Annoying" & @CRLF & _
"Redemption Key: XFHWM-T5C33-BT9JW" & @CRLF & _
"" & @CRLF & _
"Driftland: The Magic Revival (2019)" & @CRLF & _
"Floating Wizards 4X" & @CRLF & _
"Redemption Key: CEKXL-34ARQ-W622F" & @CRLF & _
"" & @CRLF & _
"Displate Discount code" & @CRLF & _
"40% off at displate (redeemable on the displate website)" & @CRLF & _
"Redemption Key: CD2N2KZ7" & @CRLF & _
"" & @CRLF & _
"Discolored (2019)" & @CRLF & _
"Perform Pigment Puzzles" & @CRLF & _
"Redemption Key: BFP3L-KHCQH-CYYJQ" & @CRLF & _
"" & @CRLF & _
"DESOLATE (2019)" & @CRLF & _
"Coop Zombie Survival" & @CRLF & _
"Redemption Key: 4AVFQ-MHV3F-TEH33" & @CRLF & _
"" & @CRLF & _
"Deponia (2014)" & @CRLF & _
"Iconic Point-and-Click" & @CRLF & _
"Redemption Key: YNMK3-87GGA-7GIBR" & @CRLF & _
"" & @CRLF & _
"Demolish & Build 2018 (2018)" & @CRLF & _
"Knock Stuff Over" & @CRLF & _
"Redemption Key: K4LE8-VLEG2-5D92N" & @CRLF & _
"" & @CRLF & _
"delta: Rings of Saturn (2019)" & @CRLF & _
"Realistic Space Mining" & @CRLF & _
"Redemption Key: J3K05-7G406-7DQDP" & @CRLF & _
"" & @CRLF & _
"Dark Nights with Poe and Munro (2020)" & @CRLF & _
"Supernatural FMV Strangeness" & @CRLF & _
"Redemption Key: TPW4R-CAZ67-AX7II" & @CRLF & _
"" & @CRLF & _
"Danger Scavengers (2021)" & @CRLF & _
"Cyberpunk Rooftop Romp" & @CRLF & _
"Redemption Key: 4F0DX-W4T09-3JIQC" & @CRLF & _
"" & @CRLF & _
"CryoFall (2021)" & @CRLF & _
"Sci-fi Multiplayer Survival" & @CRLF & _
"Redemption Key: 4P6KY-40C3X-3ENQR" & @CRLF & _
"" & @CRLF & _
"Crazy Machines 3 (2016)" & @CRLF & _
"Wacky Physics Sandbox" & @CRLF & _
"Redemption Key: T3QXN-V0WR8-4JKVV" & @CRLF & _
"" & @CRLF & _
"ConnecTank (2021)" & @CRLF & _
"Coop Conveyer Battles" & @CRLF & _
"Redemption Key: AYZVT-D8F8B-LW9IJ" & @CRLF & _
"" & @CRLF & _
"Concrete Jungle (2015)" & @CRLF & _
"Classic City Builder" & @CRLF & _
"Redemption Key: WJG8H-BR0VM-0HIZE" & @CRLF & _
"" & @CRLF & _
"City Climber (2017)" & @CRLF & _
"Ragdoll Climbing Fun" & @CRLF & _
"Redemption Key: C7LPY-ZD0ZM-638X2" & @CRLF & _
"" & @CRLF & _
"CHUCHEL (2018)" & @CRLF & _
"Comedy Mushroom Adventure" & @CRLF & _
"Redemption Key: GEW0J-CW9BJ-HHGT4" & @CRLF & _
"" & @CRLF & _
"Chronicon (2020)" & @CRLF & _
"Live Loot Level-Up" & @CRLF & _
"Redemption Key: HE8CZ-3LPE6-RKJW3" & @CRLF & _
"" & @CRLF & _
"Chroma Squad (2015)" & @CRLF & _
"Power Ranger Manager" & @CRLF & _
"Redemption Key: R2QGM-JIH70-57H2Q" & @CRLF & _
"" & @CRLF & _
"Chatventures (2020)" & @CRLF & _
"Popping Micro-games" & @CRLF & _
"Redemption Key: CKTGT-LWT97-4TH2C" & @CRLF & _
"" & @CRLF & _
"Chaos Reborn (2015)" & @CRLF & _
"Tactical Wizard Wars" & @CRLF & _
"Redemption Key: 4AMFE-PEEFN-4IE2X" & @CRLF & _
"" & @CRLF & _
"Bonfire Peaks (2021)" & @CRLF & _
"Atmospheric Burning Puzzles" & @CRLF & _
"Redemption Key: DL3EA-4C2VD-TFB3M" & @CRLF & _
"" & @CRLF & _
"Big Crown Showdown (2018)" & @CRLF & _
"Frantic Fall-Knights" & @CRLF & _
"Redemption Key: AL4G8-CFJ06-GL0X6" & @CRLF & _
"" & @CRLF & _
"Ato (2020)" & @CRLF & _
"Cat Samurai Adventure" & @CRLF & _
"Redemption Key: EDE9C-8YNTQ-H9CXT" & @CRLF & _
"" & @CRLF & _
"Aporia: Beyond The Valley (2017)" & @CRLF & _
"Stunning Story Puzzler" & @CRLF & _
"Redemption Key: KJI3R-6FMTH-9KJ6H" & @CRLF & _
"" & @CRLF & _
"Ancient Enemy (2020)" & @CRLF & _
"Modern Fantasy Solitaire" & @CRLF & _
"Redemption Key: 0JYQ0-W5QXM-9LW3Y" & @CRLF & _
"" & @CRLF & _
"Age of Wonders: Planetfall (2019)" & @CRLF & _
"Beautiful Sci-Fi 4X" & @CRLF & _
"Redemption Key: 447DM-IW4Y7-TZRMG" & @CRLF & _
"" & @CRLF & _
"Aeronautica Imperialis: Flight Command (2020)" & @CRLF & _
"Turn-based Top Gun" & @CRLF & _
"Redemption Key: KPH7N-22L7D-AX5TD" & @CRLF & _
"" & @CRLF & _
"Absolute Drift (2015)" & @CRLF & _
"Chill Drifting" & @CRLF & _
"Redemption Key: YWHF9-6KTFI-CPRLL" & @CRLF & _
"" & @CRLF & _
"A Total War Saga: TROY (2021)" & @CRLF & _
"Swords Sandals Slaughter" & @CRLF & _
"Redemption Key: K4B0G-6WA7G-3XN25" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")