package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Za-z-.]{1,}@{1}[A-Za-z-]{2,}.{1}[A-Za-z-]{2,}`)
var str = `Jean-Martial Sabot;lportaux@msi-nord.fr`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}