re = /^([-\w]|[-\w][-.\w]*[-\w])@([-a-zA-Z0-9]+\.)+[-a-zA-Z0-9]{2,4}$/
str = 'john@gddg.com
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end