#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=[^0-9][^0-9]\s)(?P<val>[1-9]|[1-2][0-9]|3[0-3])(?=\s[^a-z\s]+\s[^a-z\s]+\s[^a-z\s]+$)"
Local $sString = "Increase)/Decrease in inventories -6,999,009 3,784,581" & @CRLF & _
"Increase)/Decrease in receivables -7,393,450 3,842,984" & @CRLF & _
"Increase/(Decrease) in payables 5,821,857 -18,006,883" & @CRLF & _
"Grant received 0 625,255" & @CRLF & _
"Interest paid -565,584 -1,495,877" & @CRLF & _
"Tax paid -22,168 -21,694" & @CRLF & _
"The annexed NOTEs form an integral part of the financial statements." & @CRLF & _
"36" & @CRLF & _
"Annual Report 2012" & @CRLF & _
"Pentamaster Corporation Berhad (5723070 ) www.pentamaster.com" & @CRLF & _
"CONSOLIDATED STATEMENT OF CASH FLOWS" & @CRLF & _
"FOR THE YEAR ENDED 31 DECEMBER 2012 (CONT'D)" & @CRLF & _
"2012 2011" & @CRLF & _
"RM RM" & @CRLF & _
"CFI" & @CRLF & _
"Dividend income 80,863 81,078" & @CRLF & _
"Interest received 67,568 316,523" & @CRLF & _
"Proceeds from disposal of property, plant and equipment/non current assets held for sale 27 28,000 48,298,000" & @CRLF & _
"Purchase of property, plant and equipment 27 -64,624 0" & @CRLF & _
"CFF" & @CRLF & _
"Short term borrowings obtained/(repaid) 6,367,671 -4,757,230" & @CRLF & _
"Net term loans repaid -3,382,414 -40,376,659" & @CRLF & _
"Net Cash Flow -838,456 -168,122" & @CRLF & _
"Cash and cash equivalents brought forward 5,939,258 6,147,628" & @CRLF & _
"FOREIGN CURRENCY EXCHANGE" & @CRLF & _
"DIFFERENCES ON OPENING BALANCE 35 -40,248" & @CRLF & _
"Cash and cash equivalents carried forward 5,100,837 5,939,258" & @CRLF & _
"RM RM" & @CRLF & _
"CFO" & @CRLF & _
"Loss)/Profit before taxation -2,083,184 2,145,073" & @CRLF & _
"Adjustments for :0" & @CRLF & _
"Amortisation of intangible assets 2,689,572 4,087,413" & @CRLF & _
"Bad debts written off 7,594 0" & @CRLF & _
"Deferred income released -1,854,722 -3,786,856" & @CRLF & _
"Depreciation 2,855,169 2,941,851"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")