$re = '/^[0-9]{2}-[0-9]{3}/';
$str = '02-456';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);