# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\s*?NAME\s*?:\s*?\"?)([0-9A-Za-z- ,]+)(?:\"?\s*?,\s*?)(?:DESCR\s*?:\s*\"?)([0-9A-Za-z- ,/+:]+)(?:\"?\s*?PID\s*?:\s*?)([0-9A-Z-]+)(?:\s*?,\s*?VID\s*?:\s*?)([0-9A-Z/]+)(?:\s*?,\s*?SN\s*?:\s*?)([0-9A-Z/]+)"
test_str = ("NAME: \"Chassis\", DESCR: \"Nexus C9348GC-FXP chassis\"\n"
"PID: N9K-C9348GC-FXP , VID: V01 , SN: FFFFFFFFFFF\n\n"
"NAME: \"Slot 1 \", DESCR: \"48x100M/1G \"\n"
"PID: N9K-C9348GC-FXP , VID: V01 , SN: FFFFFFFFFFF\n\n"
"NAME: \"GEM \", DESCR: \"4x25G+2x100G Switch \"\n"
"PID: N9K-C9348GC-FXP , VID: V01 , SN: FFFFFFFFFFF\n\n"
"NAME: \"power Supply 1\", DESCR: \"PSU \"\n"
"PID: NXA-PAC-350W-PE , VID: V01 , SN: DDDDDDDDDDD\n\n"
"NAME: \"power Supply 2\", DESCR: \"PSU \"\n"
"PID: NXA-PAC-350W-PE , VID: V01 , SN: DDDDDDDDDDD\n\n"
"NAME: \"Fan 1 \", DESCR: \"fan \"\n"
"PID: NXA-FAN-30CFM-F , VID: N/A , SN: N/A\n\n"
"NAME: \"Fan 2 \", DESCR: \"fan \"\n"
"PID: NXA-FAN-30CFM-F , VID: N/A , SN: N/A\n\n"
"NAME: \"Fan 3 \", DESCR: \"fan \"\n"
"PID: NXA-FAN-30CFM-F , VID: N/A , SN: N/A")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.