$re = '/((<(.)*\\\\>)|( |\t)|(\n))*/';
$str = '<p\\> <p\\>
<br \\> <br\\>
<teste \\>
<\\ 123>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);