$re = '/((?!\[)\w+(?=\]))/i';
$str = '[python] or [html] how to "how to" user:2525';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);