re = /\/([^!\/]*)\/[^!\/]*$/
str = 'de/bonprix/app/servermon/ServerMonUserInterface/0.0.5-SNAPSHOT/ServerMonUserInterface-0.0.5-20141002.113035-4.war'
# Print the match result
str.match(re) do |match|
puts match.to_s
end