package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((\w+ ){5})group to(( \w+){5})`)
var str = `A repeated capturing group will only capture the last iteration. Put a capturing group around the repeated group to capture all iterations or use a non-capturing group instead if you're not interested in the data`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}