using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(-\s)|(~\s)|([a-eA-E]\))|(\d[\.])";
string input = @"grek. afs.
mat. to‘r shaklidagi (to'rsimon) nomogramma; nomogramma (turli kattaliklar o ‘r- tasidagi o ‘zaro bog ‘lanishni ko ‘rsatadigan va ular- ni topishni osonlashtiradigan grafik chizma). mat. to‘r shaklidagi (to'rsimon) nomogramma; nomogramma (turli kattaliklar o ‘r- tasidagi o ‘zaro bog ‘lanishni ko ‘rsatadigan va ular- ni topishni osonlashtiradigan grafik chizma).
1) bot. abaka daraxli yoki shu daraxtdan qilingan ip; 2) kanoptola; 3) me'mor. boshtirgak. 1) bot. abaka daraxli yoki shu daraxtdan qilingan ip; 2) kanoptola; 3) me'mor. boshtirgak.
I) orqaga; 2) orqasidan; 3) or- qasi bilan; to hold oneself - from......dan o‘zini uzoqda olib yurmoq; to stand ~ from dan o'zini olib qochmoq. I) orqaga; 2) orqasidan; 3) or- qasi bilan; to hold oneself - from......dan o‘zini uzoqda olib yurmoq; to stand ~ from dan o'zini olib qochmoq.
yitr. katta o‘g‘irlik yoki molni o‘g‘irlash. yitr. katta o‘g‘irlik yoki molni o‘g‘irlash.
marmar plita. marmar plita.
deng. qayiqning orqasidan, qayiqning izidan; 2.prep, orqasida(n), ketida(n); keyin; ~ the beam traverz orqasidan (traverz- kemaning yo'nalishiga perpendikular bo'lgan yon I onion). deng. qayiqning orqasidan, qayiqning izidan; 2.prep, orqasida(n), ketida(n); keyin; ~ the beam traverz orqasidan (traverz- kemaning yo'nalishiga perpendikular bo'lgan yon I onion).
1) bosh tortmoq; bekor qilmoq; to ~ a right huquqni bekor qilmoq; 2) tashlab ketmoq; 3) adashtirmoq; 4) qoldir- moq; 2. n odobsizlik; o'zini tuta olmaslik. 1) bosh tortmoq; bekor qilmoq; to ~ a right huquqni bekor qilmoq; 2) tashlab ketmoq; 3) adashtirmoq; 4) qoldir- moq; 2. n odobsizlik; o'zini tuta olmaslik.
bosh tortgan, bahridan o'tgan, voz kechgan; tashlab ketilgan, qoldi- rilgan; tashlandiq, tashlandi; an ~ child tashlab ketilgan bola. bosh tortgan, bahridan o'tgan, voz kechgan; tashlab ketilgan, qoldi- rilgan; tashlandiq, tashlandi; an ~ child tashlab ketilgan bola.
kemani falokatdan sug'urta qilish. kemani falokatdan sug'urta qilish.
1) qarovsiz qoldirib ketish; 2) yur. bolasini yoki xotinini tashlab ketish. 1) qarovsiz qoldirib ketish; 2) yur. bolasini yoki xotinini tashlab ketish.
1) kamsitish; 2) tu- shirish (mansabdan). 1) kamsitish; 2) tu- shirish (mansabdan).
uyaltirmoq, uyallirib qo'ymoq, uyatga qoldirmoq, xijolat qilmoq, xijolatga solmoq. uyaltirmoq, uyallirib qo'ymoq, uyatga qoldirmoq, xijolat qilmoq, xijolatga solmoq.
uyalib qolish, xijolat bo'lish, xijolat tortish. uyalib qolish, xijolat bo'lish, xijolat tortish.
I) kuch-quvvatdan qolish, zaiflashish; ~ of noise a) shovqin bilan kurashish; b) shovqinning pasayishi; 2) tushirish (narxni, soliqni); to make - narxni tushirmoq; 3) yur. bekor qilish; - of action sud ishini to‘x- tatmoq. I) kuch-quvvatdan qolish, zaiflashish; ~ of noise a) shovqin bilan kurashish; b) shovqinning pasayishi; 2) tushirish (narxni, soliqni); to make - narxni tushirmoq; 3) yur. bekor qilish; - of action sud ishini to‘x- tatmoq.
to'qim. arqoq. to'qim. arqoq.
abbat unvoni, abbatlik. abbat unvoni, abbatlik.
abbatlik (katoliklar monastiri va unga qarashli yer-mulk), monastir; the Abbey Vestminstr abbatligi. abbatlik (katoliklar monastiri va unga qarashli yer-mulk), monastir; the Abbey Vestminstr abbatligi.
abbat (1. katolik erkaklar mo- nastirining boshlig'i; 2. Fransiyada: katoliklar ruhoniysi). abbat (1. katolik erkaklar mo- nastirining boshlig'i; 2. Fransiyada: katoliklar ruhoniysi).
qisqartirmoq; ~d qisqartirilgan. qisqartirmoq; ~d qisqartirilgan.
qisqartirish; qis- qartma. qisqartirish; qis- qartma.
1) alifbo; ~ book alifbo kitobi; 2) asos, negiz. 1) alifbo; ~ book alifbo kitobi; 2) asos, negiz.
kechmoq, voz kechmoq, yuz o'girmoq, bahridan o'tmoq, o'zini mahrum qilmoq (taxtdan, hokimiyatdan, o'zhuquqidan). kechmoq, voz kechmoq, yuz o'girmoq, bahridan o'tmoq, o'zini mahrum qilmoq (taxtdan, hokimiyatdan, o'zhuquqidan).
kechish, voz kechish, yuz o'girish, bahridan o'tish, o'zini mahrum qilish (nimadandir). kechish, voz kechish, yuz o'girish, bahridan o'tish, o'zini mahrum qilish (nimadandir).
1) anat. qorin, qorin bo'shlig'i; retracted - ichiga kirgan qorin; 2) zool. qorin (qushlarda). 1) anat. qorin, qorin bo'shlig'i; retracted - ichiga kirgan qorin; 2) zool. qorin (qushlarda).
anat. qoringa oid, qorin. anat. qoringa oid, qorin.
semiz, yo'g'on, qor- ni katta. semiz, yo'g'on, qor- ni katta.
anat. ajratadigan (mus- kullar to'g'risida), mushaklarning tortilishi.
anat. ajratadigan (mus- kullar to'g'risida), mushaklarning tortilishi.
o‘g‘ri, o‘g‘irlovchi; olib- qochar (asosan, bolalar va ayollami). o‘g‘ri, o‘g‘irlovchi; olib- qochar (asosan, bolalar va ayollami).
deng. kemaning izidan, orqa- sidan. deng. kemaning izidan, orqa- sidan.
toqat qilmoq, chidamoq. toqat qilmoq, chidamoq.
1) alifbo tartibida joylashtirilgan; 2) oddiy, sodda; 2. n savod o'rgatadigan, o'qituvchi. 1) alifbo tartibida joylashtirilgan; 2) oddiy, sodda; 2. n savod o'rgatadigan, o'qituvchi.
1) ko'rpa-to'shakda; karavotda; 2) ko'rpa-to'shakka, karavotga. 1) ko'rpa-to'shakda; karavotda; 2) ko'rpa-to'shakka, karavotga.
bat. oq terak. bat. oq terak.
log'chumchuq (modasi). log'chumchuq (modasi).
1) to'g'ri yo'ldan chiqish; 2) biol. normal turdan chetga chiqish. 1) to'g'ri yo'ldan chiqish; 2) biol. normal turdan chetga chiqish.
1) adashgan, adashib qolgan, yo'lini yo'qotib qo'ygan; 2) og‘gan, chetga chiqqan, burilib ketgan; a plane on an - course belgilangan yo'ldan chetga chiqib ketgan samolyot. 1) adashgan, adashib qolgan, yo'lini yo'qotib qo'ygan; 2) og‘gan, chetga chiqqan, burilib ketgan; a plane on an - course belgilangan yo'ldan chetga chiqib ketgan samolyot.
adashish, adashib qolish, yoMini yo'qotish. adashish, adashib qolish, yoMini yo'qotish.
yomon ishga undamoq (in): to - smb. in a crime yur. kimnidir jinoyat sodir etish- ga undamoq. yomon ishga undamoq (in): to - smb. in a crime yur. kimnidir jinoyat sodir etish- ga undamoq.
ig‘vo, fitna. ig‘vo, fitna.
1) sherik; 2) g'iybatchi, g'ala- mis, fitnachi. 1) sherik; 2) g'iybatchi, g'ala- mis, fitnachi.
1) noma’lum, mavhum holat; 2) yur. vaqtincha amalda bo'lmaslik, vaqtincha bekor qilinish (qonun, huquq): the question is in- bu masalani ko'rib chiqish to'xtatildi; this rule has fallen into - bu qonun eskirgan (boshqa amal qilmaydi); in - a) mavhum, kutish holatida: b) egasiz (meros to'g'- risida); d) vaqtincha bekor qilingan (qonun to ‘g 'risida). 1) noma’lum, mavhum holat; 2) yur. vaqtincha amalda bo'lmaslik, vaqtincha bekor qilinish (qonun, huquq): the question is in- bu masalani ko'rib chiqish to'xtatildi; this rule has fallen into - bu qonun eskirgan (boshqa amal qilmaydi); in - a) mavhum, kutish holatida: b) egasiz (meros to'g'- risida); d) vaqtincha bekor qilingan (qonun to ‘g 'risida).
1) juda yomon ko'rmoq; nafrat bilan qaramoq; 2) so'zl. toqat qila olmaslik; yoqtirmaslik; my son ~s being idle o'g'lim bekor yurishni yoqlirmaydi. 1) juda yomon ko'rmoq; nafrat bilan qaramoq; 2) so'zl. toqat qila olmaslik; yoqtirmaslik; my son ~s being idle o'g'lim bekor yurishni yoqlirmaydi.
jirkanish, nafratlanish, yomon ko'rish: to hold in - nafratlanmoq, jir- kanmoq. jirkanish, nafratlanish, yomon ko'rish: to hold in - nafratlanmoq, jir- kanmoq.
1) nafrat uyg'otadigan: 2) birga yashay olmaydigan, birga bo'lolmay- digan (to - bilan). 1) nafrat uyg'otadigan: 2) birga yashay olmaydigan, birga bo'lolmay- digan (to - bilan).
rioya qilish ( nimagadir)-, ~ by rules qoidaga rioya qilmoq. rioya qilish ( nimagadir)-, ~ by rules qoidaga rioya qilmoq.
(abode, abided, abidden) 1) chidamli (pishiq) bo'lmoq; buzilmas bo'lib qolmoq: 2) ya.shamoq: umr ko'rmoq, istiqomat qilmoq; ~ at biror joyda (istiqomat qilmoq) yashamoq; - by sodiq bo'lib qolmoq: rioya qilmoq: amal qilmoq; to - by one’s promises so'zining (va’dasining) ustidan chiqmoq: my father ~s by what he said mening otam doimo aytganini qiladi; - in biror joyda (istiqomat qilmoq) yashamoq; - with kirn bilandirqolmoq. (abode, abided, abidden) 1) chidamli (pishiq) bo'lmoq; buzilmas bo'lib qolmoq: 2) ya.shamoq: umr ko'rmoq, istiqomat qilmoq; ~ at biror joyda (istiqomat qilmoq) yashamoq; - by sodiq bo'lib qolmoq: rioya qilmoq: amal qilmoq; to - by one’s promises so'zining (va’dasining) ustidan chiqmoq: my father ~s by what he said mening otam doimo aytganini qiladi; - in biror joyda (istiqomat qilmoq) yashamoq; - with kirn bilandirqolmoq.
rib. asabiylashni pasay- tirmoq. rib. asabiylashni pasay- tirmoq.
1) past, xarob, g'arib: 2) kamsitish, pastga urish. 1) past, xarob, g'arib: 2) kamsitish, pastga urish.
voz kechish, yuz o'girish. voz kechish, yuz o'girish.
yuz o'girmoq, voz kechmoq: to - one’s religion o‘z dinidan yuz o'girmoq. yuz o'girmoq, voz kechmoq: to - one’s religion o‘z dinidan yuz o'girmoq.
ko'kragidan (bag'ridan) tortib olish (bolani). ko'kragidan (bag'ridan) tortib olish (bolani).
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}