$re = '/^[A-Za-z0-9_]+$/m';
$str = 'dsadsda_d1123213123dab0b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);