# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"me"
test_str = ("https://lingojam.com/edit/02db819202047a0e482ab768cd7baec9\n\n\n"
"###name, Name of your translator...:\n"
"IRC Server Now Understands Voice\n\n\n"
"###subtitle, Subtitle (optional):\n"
"The Only Way\n\n\n"
"###language1, Language1 name...:\n"
"Antonio Rodriguez Jr. Command To Anything\n\n\n"
"###language2, Language2 name...:\n"
"Antonio Rodriguez Jr. Is Now Heard, Seen, Felt, Sense, And Vice Verca\n\n\n"
"###description, Description...:\n"
"import java.util.Scanner\n\n"
"Scanner stdin = new Scanner(System.in)\n\n"
"public class Command\n\n"
"{\n"
"public static void main(String[] args)\n\n"
"{\n\n"
" System.out.println(\"Command:\");\n\n"
"}\n\n\n\n\n"
"###email, Admin email (optional)...:\n"
"wonderfulyanderful@gmail.com\n\n\n"
"###phrases1, Language1...:\n\n\n\n"
"###phrases2, Language2...:\n\n\n\n"
"###words1, Language1...:\n\n\n\n"
"###words2, Language2...:\n\n\n\n"
"###intraword1, Language1...:\n\n\n\n"
"###intraword2, Language2...:\n\n\n\n"
"###prefixes1, Language1...:\n\n\n\n"
"###prefixes2, Language2...:\n\n\n\n"
"###suffixes1, Language1...:\n\n\n\n"
"###suffixes2, Language2...:\n\n\n\n"
"###regex1, Replace this...:\n\n\n\n"
"###regex2, with this...:\n\n\n\n"
"###rev_regex1, Replace this...:\n\n\n\n"
"###rev_regex2, with this...:\n\n\n\n"
"###ordering1, Language1...:\n\n\n\n"
"###ordering2, Language2...:\n\n\n\n"
"###defaulttext, One random default text string per line...:\n\n\n\n"
"###disable-reverse, :\n"
"on\n\n\n"
"###custom-script, Define your functions here...:\n\n\n\n"
"###title-extra, e.g. '(and reverse translation)':\n\n\n\n"
"###background-image-source, http://example.com/my_image.png:\n\n\n\n"
"###title-font-name, Name of custom font...:\n\n\n\n"
"###title-font-size, Size of title (default=5.5)...:\n\n\n\n"
"###language1-font, Language1 font...:\n\n\n\n"
"###language2-font, Language2 font...:\n\n\n\n"
"###language1-font-size, Language1 font size (default=24)...:\n\n\n\n"
"###language2-font-size, Language2 font size (default=24)...:\n\n\n\n\n\n\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.