$re = '/[^\p{L}\d\s@#]|\s/u';
$str = '/atgfsgshg/7867 867786786/456747*589.89/8///////';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);