re = /^(?=.{8,20}$)(?=.*[A-Za-z])(?=.*(?=.*[0-9]))(?=.*?[#?!@$%^&*-])(?!.*(.)\1).+$/m
str = 'Duplic4do#
Duuplic4do#
Duplic44do#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end