$re = '/(?<![s|S])’(?!s)/m';
$str = 'What’s
Whats’
What’t
Whatt’';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);