# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(http[s]?:\/\/)05542online.com/uploads/posts/(\d*\-\d*\/\w*\/\d+\w*)([-]?)(\w+\d*).jpg"
test_str = ("https://05542online.com/uploads/posts/2019-01/thumbs/1548168351_49408004_804805043204941_4917756314337148928_n.jpg\n\n"
"https://05542online.com/uploads/posts/2019-01/thumbs/1548166068_49897436_342482663009866_881291499176722432_n.jpg\n\n"
"https://05542online.com/uploads/posts/2019-01/thumbs/1548139537_bufer-obmena01.jpg")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.