#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^https?:\/\/www\.mangeznotez(dev)?\.com\/booking\/[a-z\d]+\/\d\?giftCardCode=[a-zA-Z\d]{5}"
Local $sString = "https://www.mangeznotezdev.com/booking/363acccf265c890fd0134c771ee146b1/1?giftCardCode=f2c63"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")