$re = '/^[a-zA-z.0-9]{1,50}@(gmail|outlook|hotmail|zoho|yahoo|)\.com$/m';
$str = 'sahilxresta98@gmail.com
literarl@outlook.com
sneha@yahoo.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);