re = /^([1-9]{1})([0-9]{2})([0-9]{2})([0-9]{2})([0-9]{2})[0-9]{3}([0-9]{1})[0-9]{1}$/
str = '28001150200458'
# Print the match result
str.match(re) do |match|
puts match.to_s
end