$re = '/^[0-9]{9}$/i';
$str = '222584455';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);