package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`shop\/(vegan-[^\/]*?)\/?$`)
var str = `shop/some-base/vegan-category/
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}