// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^.*\n(.*)").unwrap();
let string = "Sample 2
James B. Lapointe
1481 Keyser Ridge Road
Appartment Keyser Ridge Road
Archdale, NC 27263
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}