# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"age [0-9]*.\n(.*)"
test_str = ("Born Elon Reeve Musk\n"
"June 28, 1971 (age 50)\n"
"Pretoria, Transvaal, South Africa\n"
"Citizenship \n"
"South Africa (1971–present)\n"
"Canada (1971–present)\n"
"United States (2002–present)\n"
"Education University of Pennsylvania (BS, BA)\n"
"Title \n"
"Founder, CEO and Chief Engineer of SpaceX\n"
"CEO and product architect of Tesla, Inc.\n"
"Founder of The Boring Company and X.com (now part of PayPal)\n"
"Co-founder of Neuralink, OpenAI, and Zip2\n"
"Spouse(s) \n"
"Justine Wilson\n"
"\n"
"(m. 2000; div. 2008)\n"
"Talulah Riley\n"
"\n"
"(m. 2010; div. 2012)\n"
"\n"
"(m. 2013; div. 2016)\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.