$re = '/^[\w.-]*\@\w[\w.]*$/';
$str = 'yerko-palma@usach.cl';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);