$re = '/(?=(A[TU]G(?:.{3}){4,}(?:[TU]AG|[TU]AA|[TU]GA)))/i';
$str = 'tatgaatgaatgffffffatgfftaaftaafatgfatgfffffsdfatgffatgfffstaafftaafffffffffffffffatgtaaataa
atgffftaaf
atgffatgftaafftaa
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);