re = /^((([a-z0-9][a-z0-9\-]*[a-z0-9])|[a-z0-9]+)\.)*([a-z]+|xn\-\-[a-z0-9]+)\.?$/
str = 'terra.com.br'
# Print the match result
str.match(re) do |match|
puts match.to_s
end