#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?<raute>#(?<raute_content>[^\n]*))|(?<doubleslashes>\/\/(?<doubleslashes_content>[^\n]*))|(?<block>\/\*(?<block_content>[^*]+|\*(?!\/))*+\*\/))"
Local $sString = "blah" & @CRLF & _
"# ein Kommentar" & @CRLF & _
"blah blah // ein Kommentar" & @CRLF & _
"" & @CRLF & _
"/*" & @CRLF & _
" Ein" & @CRLF & _
"Kommentar" & @CRLF & _
" Block" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*/" & @CRLF & _
"" & @CRLF & _
"blah # ein weiteres Kommentar" & @CRLF & _
"" & @CRLF & _
"blah" & @CRLF & _
"" & @CRLF & _
"/* Zweiter Block" & @CRLF & _
"" & @CRLF & _
"Geht wieder über mehrere Zeilen */" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")