use strict;
my $str = 'P<USADOE<<JOHN<WILLIAM<<<<<<<<<<<<<<<<<<<<<<
5039927858USA5509298M2304090255136054<115916';
my $regex = qr/(?<type>[A-Z])(?<subtype>[<A-Z])(?<country>\w{3})(?<lname>[A-Z]+)(?<lname2><[A-Z]+){0,}<<(?<fname>[A-Z]+)(?<mname1><[A-Z]+){0,}(?<complement><){0,}\n(?<pnum>[\d\w]{9})(?<pnumcheck>\d{1})(?<nat>\w{3})(?<yob>\d{2})(?<mob>\d{2})(?<dob>\d{2})(?<dobcheck>\d{1})(?<sex>M|F|<{1})(?<yoe>\d{2})(?<moe>\d{2})(?<doe>\d{2})(?<expcheck>\d{1})(?<pid>[\d\w<]{14})(?<pidcheck>\d{1})(?<generalcheck>\d{1})/mp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}