#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\d|-|\/|to|\$)(?<!\$(\d)\.)([1-9][0-9]{0,2}(\.\d{0,2})?\s?)(lbs|lb|LBS|LB|KG|kg|G|g|L|l+)(?!\d|\w)"
Local $sString = "10lb Potato bag" & @CRLF & _
"Apples Gld Delicious 3lb" & @CRLF & _
"Grandfer Rocha Pear2.5lbs" & @CRLF & _
"CHIN.MAND.5LB" & @CRLF & _
"Batata Veg (10LB)" & @CRLF & _
"SIG 170LB99 Legging SzB 1ea" & @CRLF & _
"ARJO CDA1450035 SupBlk 400LB1ea" & @CRLF & _
"AHC EB205L " & @CRLF & _
"DRI 10220-1 Bariatric500lb 1 ea" & @CRLF & _
"TILDA SONA MASOORI 20 LBS" & @CRLF & _
"OVAL ROASTER 9 - 12 LBS" & @CRLF & _
"ORGANIC TRIPACK FRUIT 1.2 KG" & @CRLF & _
"KGF5KT2404 PEPLUM T, PURPLE" & @CRLF & _
"AIR 1773LB-XL 15-20 KnXL 1ea" & @CRLF & _
"PLUM BAG 1KG US" & @CRLF & _
"NEXT XTRA 100G" & @CRLF & _
"SUDOCREM 60G" & @CRLF & _
"EGGPLANT GRILLED IN OIL (3KG)" & @CRLF & _
"CORONATION GRAPE 2L CA" & @CRLF & _
"MEAT DEAL $11.00 KG" & @CRLF & _
"LIVE LOBSTER- 2.00-3.00 LB-MSC" & @CRLF & _
"PC MAGIC GROW 20-20-20 3.55KG" & @CRLF & _
"KGF7W3409 KGVELCROWB,GREY" & @CRLF & _
"TZATZIKI 500G" & @CRLF & _
"2+1 LEAD MIX"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")