package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\d+(\.\d+)?)M`)
var str = `54.323M
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}